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Abstract 
 
Every report should have an abstract. The abstract summarizes the report using between 
100 and 200 words in a single paragraph. The purpose of an abstract is so that a reader 
can quickly get an idea of the main points and contributions of the paper. The author 
often writes the abstract last. This is because it is after the body of the report is written 
that the writer gains a good overview of the contents and results of the report. All reports 
submitted to me should follow the format shown in this template. Also, if you use this 
template for reports in your courses, you will be in good shape. However, be aware that 
CSU has a separate template for theses and dissertations. 
 
 
1. Introduction 
 
All reports should have an introduction. One purpose of the introduction is to introduce 
the problem. For instance, the background of this report template is as follows: I receive a 
lot of reports from students, a lot of them have common errors in writing, grammar, and 
organization, and all of them are in different formats. It looks more professional if all the 
reports that I collect are in the same format. This is especially true if the reports are 
distributed to other people, or if they are put up on the Internet. 
 
Another purpose of the introduction is to summarize the paper. The introduction can be 
considered as an extended abstract, or the abstract can be considered as an abbreviated 
version of the introduction. The introduction should summarize the report sections. 
Section 2 of this report discusses section headings, and Section 3 discusses fonts. 
Section 4 discusses .... Finally, Section 8 contains some concluding remarks. Most reports 
will not have this many sections. A total of between four and six sections is more typical. 
 
 
2. Section headings 
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The section headings are begun with numbers. The section headings begin with a capital 
letter, but all of the other letters in the section headings are lower case. In addition, make 
sure that the section heading (or subheading) and the first two lines of the following text 
are on the same page. This section is wrong because the section heading is on a different 
page than the first two lines of the section. You can enforce this in Microsoft Word by 
selecting the section heading and the first two lines of the section, then selecting the 
menu item Format → Paragraph, then checking the check box “Keep with next.” 
 
2.1. Subheadings 
 
Subheadings are numbered with an additional numeral such as 1.1, 1.2, etc. If you have a 
1.1 subsection, then you must also have a 1.2 subsection. It does not make sense to have a 
1.1 subsection without a 1.2 subsection. This would be like trying to divide a pie into one 
piece. If you want the pie to be in one piece, then don’t divide it. If you want to divide it, 
then you have to divide it into at least two pieces. Similarly, if you want to divide a 
section into subsections, you have to divide it into at least two subsections. 
 
Note that the headings style used in this template can be automated by using the 
Microsoft Word menu item Format → Bullets and Numbering → Outline Numbered. 
 
2.2. Title 
 
Every word in the title is capitalized, except for prepositions, articles, and conjunctions 
(words like of, or, and, the, etc.). However, the first word of the title is always 
capitalized. The title should be concise, typically 10 words or less, and should avoid 
acronyms unless they are commonly known. Include your name, affiliation (e.g., 
Cleveland State University), and mailing address below the title. Include the date of the 
report below the title. If the work was done as part of your thesis research, include your 
advisor as your coauthor. If the work was done as part of a class project, do not include 
your advisor as your coauthor. Include the authors’ email addresses as a footnote on the 
first page. The footnote should also acknowledge any financial support that helped you in 
your work. This is the only time you should use a footnote in the paper. 
 
 
3. Fonts, justification, paragraphs, and spacing 
 
Section headings and subheadings are 14-point font. The title is 16-point font. All the 
other text in the report is 12-point font. Never use all capital letters (this includes the 
report title and the section headings) unless you want to convey the impression of yelling. 
All fonts should be Times New Roman. 
 
A new paragraph is indicated by skipping a line. Indents should not be used. 
 
The justification is flush left, ragged right. Don’t force all of the lines to end at the same 
point on the right margin. 
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Use single spacing throughout the report, with blank lines inserted at appropriate places 
as shown in this template. Every main heading (including the abstract and section 
headings) should be preceded by two blank lines. Every subheading should be preceded 
by one blank line. Paragraphs should separated with one blank line. 
 
Set up your page settings using the Microsoft Word default, which includes one-inch top 
and bottom margins, and 1.25-inch left and right margins. Page margins can be seen by 
selecting the Microsoft Word menu item File → Page Setup.  
 
Insert page headers and footers in your report by using Microsoft Word’s menu item 
View → Header and Footer. The first page does not need a header or footer (this is 
specified by clicking the Page Setup Button in the Header and Footer toolbar). The page 
header should contain the report title (left justified), and the report authors (right 
justified), both in 10-point italics. The page footer should contain the page number and 
the total number of pages, center justified in 10-point italics, as shown in this template. 
 
 
4. Spelling and punctuation 
 
Microsoft Word has a spell checker. Use it. 
 
Microsoft Word also has a grammar checker, although it does not work so well. But it 
cannot hurt to use it. It might help you find errors in grammar.  
 
Commas need special attention. There are two main rules to use with commas. First, 
commas should never be preceded with a space. For instance , the comma in this sentence 
is wrong because it has a space in front of it. Second, commas should always be followed 
with a space. For instance,the comma in this sentence is wrong because it does not have 
space after it. 
 
Periods should always be following by exactly one space.For instance, this paragraph is 
wrong because the period at the end of the first sentence does not have space following it. 
Some people like to use two spaces after a period − this is fine, as long as you are 
consistent. If a parenthetical phrase is at the end of a sentence, the period belongs outside 
the parenthesis (like this). However, if an entire sentence is parenthetical, the period 
belongs inside the parentheses. (Here is an example.) 
 
Integers should be spelled out if they are less than 10, or if the number begins a sentence. 
Integers should be written with numerals if they are greater than nine. Nineteen out of 20 
technical writers agree with this rule. 
 
 
5. Equations 
 
Equations should always be in italics. If you use something like Microsoft Equation 
Editor then it will format the equation for you. If you type the equation yourself in text 
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mode, then make sure that you italicize the equation. Also, every mathematical operator 
symbol should be preceded and followed with a space. For example, the equation 
 
x2 − 2x + 3 = 0 (1) 
 
was typed in text mode. It has a space before and after the minus sign, a space before and 
after the plus sign, and a space before and after the equal sign. The entire equation is 
italicized. Similarly, if you refer to any mathematical symbols in the text of your report, 
they should be italicized. For instance, we can solve the above equation for x. Notice that 
I italicized x in the previous sentence (and in this sentence too, for that matter).  
 
If you need to refer to equations by number, the equations should be numbered inside 
parentheses and aligned with the right margin, as shown above. (Insert a tab stop with a 
right alignment at the right margin.) If you need to refer to an equation later in the text, 
refer to it without using the word “equation” − just refer to it by using the equation 
number in parentheses. For example, we can solve (1) using a genetic algorithm. 
 
The minus sign is not the same as the hyphen on your keyboard. The hyphen looks like 
this: “-”. The minus sign looks like this: “−”. You can often get a minus sign by typing 
two hyphens in Microsoft Word. If that does not work, then go to the Microsoft Word 
menu item Insert → Symbol, choose the Symbol Font from the combo box, and find the 
minus sign.  
 
If you need to use a multiplication symbol, don’t use “x” (ex) and don’t use “*” 
(asterisk), but instead use “×”. This symbol can be found by selecting the Microsoft Word 
menu item Insert → Symbol, and choosing the Symbol Font. 
  
All equations should be preceded and followed by a blank line.  
 
 
6. Tables and figures 
 
Tables and figures should be numbered and have a descriptive caption (as shown in 
Table 1). Tables should appear as soon as possible after the paragraph where they are first 
referred to in the text. Each table must be referred to in the text, along with some 
discussion of the data. For instance, Table 1 shows the average soybean price in Jamaica 
and Lebanon during the years 1999 and 2000. Note the double lines between the column 
headings and columns, and the double lines between the row headings and rows, to make 
the table more readable. Note that the table, along with its caption, is center justified. 
Note that the caption is 10-point font.  
 
When you refer to a specific table in the text (for instance, “We see that Table 1 shows 
…”) you always capitalize the first letter in the word “Table.” On the other hand, if you 
are referring to a table without using a number, then the first letter in the word “table” is 
not capitalized. For instance, “This table shows the average soybean prices in Jamaica 
and Lebanon during the years 1999 and 2000.” The same rule applies to designators like 
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“figure” and “section.” If you want to refer to a specific section, then always capitalize 
the word “section” − for example, “In Section 6 we discuss tables and figures.” If you are 
the word “section” in a more generic manner, then do not capitalize it − for example, “In 
this section we discuss tables and figures.” This is like personal titles. For instance, if you 
are using a title with a specific person you capitalize their title, but if you are not using 
the title with a specific person’s name then you do not capitalize the title. “The history 
books tell us that President Washington was the first president of the United States.” Or, 
“One of the pickiest professors I’ve ever seen is Professor Simon.” 
 
Always insert a blank line before and after each table. 
 

 Jamaica Lebanon 
1999 1.98 3.14 
2000 2.45 3.03 

Table 1 − Average soybean prices (dollars per bushel) 
 
The same general rules apply to figures. Note that figure captions do not have to be short. 
In fact, the more descriptive a figure caption is, the better. The reader should not have to 
delve into the text in order to understand a figure. The reader should be able to 
understand the figure by looking at the figure along with the caption. Also, figures should 
always have a white background. Matlab often creates figures with a gray background, 
but you need to change it to white (using Matlab options) before you put it in a report. 
The figure axes should always be labeled and legible. You can use color, but make sure 
the lines will be distinguishable if the report is printed in black and white. 
 
Figure 1 is a bad figure. Although it uses different colors for the lines, which is good, 
both lines are solid. So when the report is printed on a black and white printer the two 
lines will not be distinguishable from one another. Also, part of the background is gray, 
which is bad. Conserve toner! Also, the numbers on the axes are too small. Finally, the 
axes are not labeled. 
 

 
Figure 1 − Bad figure. The reason this figure is bad is because the font is too small, the axes are not labeled, 

the traces are not labeled, and the background is gray instead of white. 
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Figure 2, on the other hand, is a better figure. The entire background is white. The lines 
are different styles (one is solid and one is dashed) so they will be distinguishable when 
printed on a black and white printer. The axes are labeled (including units) and the two 
traces are labeled with a legend. Finally, the axis labels and numbers are large enough to 
read. All of this formatting can be done within Matlab. Notice that Figure 2 has gridlines, 
which (in general) provides a more professional appearance to a graph. 
 

 
Figure 2 − Good figure. The font is nice and big, the axes are labeled (including units), the traces are 

labeled (input and output), and the background is white. Also, the caption is long enough to be descriptive. 
 
Speaking of units, when referring to some quantity and its units, separate the quantity 
from the units with a space. For instance, the minimum voltage in Figure 2 is −1 mV. 
Note the space between the “−1” and “mV.” You would never write, “Today for lunch I 
had 10bananas.” Instead you write, “Today for lunch I had 10 bananas.” Your 
microcontroller voltage supply is not “5V.” It is “5 V.” 
 
When you use the word Table, Figure, Section, Chapter, or some other designator, along 
with a number, the designator must always be on the same line as the number. Table 
1 shows soybean prices, but this sentence is not correct because the word “Table” and the 
number “1” are on separate lines. In Microsoft Word you can insert a space that does not 
allow a line break by typing Ctrl-Shift-Space. So instead of typing T-a-b-l-e-<space>-1, 
you should type T-a-b-l-e-<Ctrl-Shift-Space>-1. 
 
 
7.  References and appendices 
 
Most reports should include references. It is hard to imagine a report without references. 
References should be arranged either alphabetically or in order of appearance in the text. 
(I prefer alphabetical, but most journals and authors prefer order of appearance.) Every 
reference that is listed should be referred to in the text, but the abstract should not contain 
any references. References should be referred to with the reference number in square 
brackets. When the reference list is finally presented at the end of the report, the word 
“References” is not preceded by a number; that is, the references section is an 
unnumbered section. 
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The purpose of including references is so that the reader can look up those references. 
Make sure the reference has enough information so that the reader can obtain the 
references. Reference [1] shows how to refer to a thesis or dissertation. Note that at the 
beginning of a sentence, a reference must be preceded by the word “Reference.” 
However, in the middle of a sentence, the reference is never preceded by the word 
“Reference.” For example, [1] shows how to refer to a thesis or dissertation. Reference 
[2] shows how to refer to a journal publication. Reference [3] shows how to refer to a 
web page, but Internet references are generally discouraged because the links get broken 
so quickly. Also, most Internet references are not reliable enough to include in a 
professional report. To be specific, Wikipedia references should never be included in a 
formal report. Wikipedia is a good source of information, but any information gathered 
from Wikipedia needs to be checked with a refereed publication (conference, book, or 
journal) before that information is included in a report, and then it is the refereed source 
that needs to be listed in the reference list. Reference [4] shows how to refer to a 
conference publication, and [5] has a template that can be used for writing a thesis at 
Cleveland State University. Reference [6] shows how to refer to a book, and [7] shows 
how to refer to a contributed chapter in an edited volume (i.e., the chapter author is 
different than the book editor). 
 
Appendices are included after the references and are labeled Appendix 1, Appendix 2, 
etc. Appendices contain material that is not essential to understanding the report, but that 
an interested reader can refer to for the sake of completeness. For instance, detailed 
mathematical proofs, schematics, and program listings could all be included in 
appendices. 
 
 
8.  Conclusion 
 
All papers should have a conclusion. This template has discussed various aspects of 
report writing. The student who attempts to follow these guidelines will see a marked 
improvement in his or her written communication skills. Like anything else, good writing 
takes practice. Don’t get discouraged if you don’t get it right the first time. Just keep 
practicing.  
 
One purpose of a conclusion is to summarize the report. For instance, in this report we 
discussed how sections should be numbered, and how the title should be formatted. We 
also discussed what types of fonts should be used at various points of the report. We 
talked about spelling, punctuation, and equation formatting. We talked about the proper 
use of tables and figures, and finally we talked about how references should be formatted. 
 
Another purpose of the conclusion is to summarize the benefits and drawbacks of the 
material that was presented. For instance, I could say that the benefit of this report 
template is that students now have a guideline that will improve their writing skills. 
However, a drawback of this template is that students may feel that they are spending 
more time on writing and report formatting rather than technical research. Each student 
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needs to strike a balance between time spent on technical work, and time spent on writing 
and other communication skills. 
 
The final purpose of the conclusion is to present ideas or proposals for future work that 
could be conducted either by the author or by someone else. For example, this report 
could be expanded in the future by including additional grammatical rules and guidelines. 
 
Finally, it should be noted that a paper could violate a lot of the rules discussed here and 
still be an excellent paper. For instance, you could use different margins, right 
justification instead of ragged right margins, different font sizes or styles, different 
capitalization rules, or a host of other choices. The important thing is to be consistent. It 
does not matter too much if you capitalize the first letter of every word of your figure 
captions, or just the first letter of the first word, as long as you are consistent. It does not 
matter if you use a different font size, as long as you are consistent. Inconsistency in 
these matters is a sure way to produce a paper with a sloppy look. 
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